Mid Century Cadillacs

61-62 Cadillac Owners Group => Introductions => Topic started by: Nagogx on November 30, 2015, 01:50:48 AM

Title: Another Kiwi back on board
Post by: Nagogx on November 30, 2015, 01:50:48 AM
Hi all! Mike here from Christchurch NZ. So glad this forum is back up and running. I really missed my daily read of the new posts on the old forum, so to see it back is a godsend. To see the old forum down is a major loss though - all that accumulated knowledge gone. So sad.

 Some of you may recall I had some majorly frustrating issues with the 62 and almost gave up on the whole project.

However, after a year of doing absolutely nothing to it, and the newly built engine languishing on the garage floor I finally have some motivation returning  and just last weekend dropped the engine back in.

Since its been a while I am bound to have forgotten where some of the parts came from and no doubt will be hoping to pick the experts brains  :D

Title: Re: Another Kiwi back on board
Post by: 61rocket on November 30, 2015, 03:08:31 AM
Good to see you back and good to hear you have got some motivation back ( wish I could say the same ) You know someone on here will always know where that mystery part goes .

Lance

Title: Re: Another Kiwi back on board
Post by: Sixfins on November 30, 2015, 05:11:01 AM
Mike, motivation ebbs and flows. It always leaves and most of the time returns. Even Einstein had great burst of activity and long periods of relative quiet. So, your right on schudule. As to knowledhe. It might bot be in print but its still here. Art
Title: Re: Another Kiwi back on board
Post by: Dan LeBlanc on November 30, 2015, 07:29:05 AM
Welcome back Mike.
Title: Re: Another Kiwi back on board
Post by: 62droptop on November 30, 2015, 09:43:54 PM
welcome back Mike

glad you got your motivation back

anything you need an answer on,fire away

someone here will know the answer and probably be able to take a nice picture too to help show

start a build thread again to post some pics of where you are now
Title: Re: Another Kiwi back on board
Post by: screamer on December 01, 2015, 10:54:50 PM
Welcome back Mike.
Nice to see you havent given up...i was wondering...
I seem to recall you had issues getting your rebuilt 63 390 started?
Title: Re: Another Kiwi back on board
Post by: Nagogx on December 02, 2015, 04:10:40 AM
Thanks guys.

Gidday Steve...yep, problems with the rebuilt engine. Was so bummed for a while I went & bought an old Lincoln to cruise around in till I found my enthusiasm.

Now the wife is used to the Lincoln being around I think Ill just keep that too lol

Your car is looking great with the new paint job!
Title: Re: Another Kiwi back on board
Post by: Dan LeBlanc on December 02, 2015, 07:20:43 AM
I like Lincolns.  What did you get?
Title: Re: Another Kiwi back on board
Post by: Nagogx on December 02, 2015, 11:26:30 PM
73 Mark 4. Its a bit rough around the edges, just how I like them.
Title: Re: Another Kiwi back on board
Post by: 61rocket on December 03, 2015, 03:03:49 AM
What a monster . Almost looks like it was taken with a fish eye lens on the camera . Certainly wouldn't be many of them driving around Kiwi land . Looks mean .

Lance
Title: Re: Another Kiwi back on board
Post by: 62droptop on December 03, 2015, 11:10:58 PM
Damn,probably a 460 fuel miser in that bad boy
should be 4 wh disc brakes too
Title: Re: Another Kiwi back on board
Post by: 62-squared on December 04, 2015, 12:45:06 AM
Cannon! Starring William Conrad...  :-)

I had a 72 Tbird, virtually the same car without the grille and with a 429 instead of a 460.  I loved it, but it only got up to 8mpg once I replaced the stuck caliper.  6mpg before that. 

That is a great ride, Mike - enjoy!  (and very glad to see you back on the forum)
Title: Re: Another Kiwi back on board
Post by: screamer on December 13, 2015, 05:32:07 PM
Wow The Lincoln is awesome mate.
What a beast.