Author Topic: '56 Engine Installed at last  (Read 860 times)

Offline The Johnny

'56 Engine Installed at last
« on: November 07, 2016, 07:35:40 PM »
Folks,

Got the rebuilt engine and tranny installed in the '56 Cad today. It should have been done a year ago but health issues got in the way.

First try was with the exhaust manifolds installed, with the battery try installed and the new battery in it. Was too tight a fit so pulled it back out and removed both manifolds. Also changed adjuster to one that would allow me to move the angle of the engine much easier.

Went in with a little brute force but nothing broken, no blood spilt. The front motor mount bolts as usual were a pain to install on the frame but it is in. Yay!

Now all that is left is putting another 300 pounds of parts on. The AC pump is 60 lbs by itself...

Pictures attached.

The Johnny

Offline South_paw

Re: '56 Engine Installed at last
« Reply #1 on: November 07, 2016, 07:42:54 PM »
Looking good Johnny. Now get her done before the snow flies   ;D
Lou
1956 Eldorado Biarritz
CLC Member since 2001 (Unlisted in Directory)



*** Check out the 1956 Eldorado Biarritz Survivor Roster. Click here ***

Offline Lexi

Re: '56 Engine Installed at last
« Reply #2 on: November 07, 2016, 10:02:27 PM »
Johnny that is beautiful. Wish you and your car the best of health. Clay/Lexi

Offline The Johnny

Re: '56 Engine Installed at last
« Reply #3 on: November 07, 2016, 11:33:57 PM »
Lexi,

NO way it is original but had the old girl since '78.

Will work on the paint next, but still need to restore the '38 before my daughter puts me in the home!

The Johnny